As reported by The Hacker News, Drupal has disclosed a highly critical authorization bypass vulnerability in its Commerce Core module that is being actively exploited in the wild. The flaw, tracked as CVE-2026-118539, represents a significant risk to any organization leveraging Drupal for e-commerce operations — and it demands immediate attention from security teams.
Why This Vulnerability Matters
What makes CVE-2026-118539 particularly dangerous is its nature as a missing authorization flaw rather than a simple injection or XSS issue. Missing authorization bugs mean that even authenticated, low-privilege users — or in some cases unauthenticated actors — can access routes and manipulate entity fields that should be restricted. In an e-commerce context, this translates directly to financial risk: attackers could potentially alter pricing, manipulate order data, access customer payment information, or bypass checkout controls entirely.
Drupal's own advisory acknowledges that the vulnerability "may financially impact the vendor," which is an unusually direct statement about real-world business consequences. When an open-source project of Drupal's stature confirms active exploitation without providing additional details about the campaign, it typically signals that threat actors discovered the flaw independently and began weaponizing it before defenders had time to prepare.
Affected Versions and Patching Status
| Detail | Information |
|---|---|
| CVE | CVE-2026-118539 |
| CVSS | Not yet assigned (rated "highly critical" by Drupal) |
| Vulnerability Type | Missing authorization / Access bypass |
| Affected Versions | 0.0.0 to 2.41; 3.0.0 to 3.3.13 |
| Patched Versions | Commerce Core 3.3.13 (3.x branch); Commerce Core 8.x-2.41 (earlier branches) |
| Active Exploitation | Confirmed in the wild |
| Researchers | Dan Puccetti, Marcus Johansson, Robert Snyder |
Who Is Most at Risk
Any organization running Drupal Commerce Core for online sales is exposed, but the risk profile varies significantly based on deployment configuration. Sites that expose decoupled API endpoints for checkout or cart operations face heightened exposure, as API routes are more likely to be enumerated and targeted by automated exploitation tools. Additionally, organizations running older 2.x branch versions — which may have been deferred for upgrade due to compatibility concerns — are at particular risk, as these versions have been vulnerable for the entire lifespan of the flaw.
Small-to-medium e-commerce businesses are often the most exposed in practice: they tend to lack dedicated security teams, may not subscribe to Drupal security mailing lists, and frequently run module versions that lag behind current releases. Attackers know this and actively scan for these targets.
Broader Context: PHP2Shell Campaign Overlaps
The Drupal advisory arrives alongside continued exploitation of two critical PHP vulnerabilities — CVE-2026-109618 and CVE-2026-109619, collectively dubbed "PHP2Shell" (CVSS 9.2). According to Wiz research cited in the same report, approximately 52.1% of organizations remain significantly affected as of October 25, 2026. While these are distinct issues, the overlap matters: organizations running vulnerable PHP versions alongside unpatched Drupal Commerce modules face compounded risk. An attacker who gains initial access through PHP2Shell could leverage the Commerce Core authorization bypass for lateral movement and financial data access.
The convergence of active exploitation across both the PHP runtime layer and the Drupal application layer creates a particularly hostile environment for e-commerce infrastructure running on outdated stacks.
Shield53 Recommendations
Immediate Actions
Longer-Term Hardening
- Subscribe to Drupal security advisories at drupal.org/security to receive immediate notifications for future vulnerabilities affecting your stack.
- Implement continuous vulnerability scanning for all Drupal modules, not just core. Third-party module vulnerabilities are a frequent initial access vector.
- Enforce least-privilege access on all commerce-related Drupal roles. Many deployments grant excessive permissions to authenticated user roles by default.
- Deploy runtime application protection (RASP) or API security monitoring to detect authorization bypass attempts in real time, complementing traditional WAF defenses.
The presence of active exploitation means the window between disclosure and attack has effectively closed. Organizations should treat this as an emergency patching event — not a routine update — and prioritize accordingly in their change management processes.